Smartcar Connect and API 5xx Errors

Incident Report for Smartcar

Postmortem

Smartcar API service had a downtime from 2/26/2025 04:32:00 PM PST - 04:50:00 PM PST for a total of 18 minutes of service impact. During this time API service experience a partial outage. A small portion of our incoming request were being serviced. The partial outage was caused by a bad code merge in API. This lead to a out memory error for our containers. The issue was resolved by rolling back the deployment. If you have any additional questions, feel free to reach out to us at support@smartcar.com.

Posted Feb 28, 2025 - 18:44 UTC

Resolved

We experienced a brief period of downtime for Connect and API services between 4:32 PM and 4:50 PM PST due to an issue introduced in a recent code update. A fix has been implemented, and all services are now fully operational. We are closely monitoring the system to ensure continued stability and will share additional details as we complete our investigation. Thank you for your patience and understanding.
Posted Feb 27, 2025 - 03:53 UTC

Monitoring

We have identified the cause of the issue affecting Connect and API requests. The outage was caused by an issue introduced in a recent code update. The change has been reverted and services are returning to normal. We are monitoring the system to ensure stability.
Posted Feb 27, 2025 - 00:55 UTC

Investigating

We are currently investigating an outage resulting in 5xx errors in Connect and API. We will provide updates as soon as more information becomes available. Thank you for your patience.
Posted Feb 27, 2025 - 00:48 UTC
This incident affected: Smartcar API and Smartcar Connect.